You are not logged in.

Announcement

Forum database was corrupt and an old backup was restored as temporary replacement. Registrations closed until the database is recovered. Please ask questions using the Contact form

#1 04-05-2013 01:48:52

Atharos
Contributors
Registered: 03-05-2013
Posts: 7

Problem with $hashed.part

Hi! I was trying to send some data through the URL, like explained in the tutorial page, but every time i try to retry information from the $hashed.part variable i get this errors:

Notice: Use of undefined constant part - assumed 'part' in C:\xampp server\htdocs\metro4\pages\noticias.php on line 22

Notice: Undefined variable: hashed in C:\xampp server\htdocs\metro4\pages\noticias.php on line 22

Someone know why is this happening?
Thank you in advance!

Offline

#2 04-05-2013 09:44:41

Thomas
Administrator
Registered: 10-03-2013
Posts: 897

Re: Problem with $hashed.part

Hello, the $hashed.part var is a javascript variable, not PHP wink

But there'll normally be a method in a next version to pass them to PHP.

Offline

#3 04-05-2013 18:46:54

Atharos
Contributors
Registered: 03-05-2013
Posts: 7

Re: Problem with $hashed.part

I tried to call the variable by Javascript, but i get always an 'undefined' value :S.
Any idea?
I wold also love to know how did you built this amazing forum template yikes

Thanks!

Last edited by Atharos (04-05-2013 18:47:50)

Offline

#4 04-05-2013 19:37:26

Thomas
Administrator
Registered: 10-03-2013
Posts: 897

Re: Problem with $hashed.part

Oh, in v4 it's $hashed.parts (and it's an array, in v3, $hashed.part was a var)

and for the forum, I've manually edited the fluxbb templates but it's not ready to put as a download because many things aren't styled (mainly the things that you can't see now, like admin panel etc wink )

Offline

#5 04-05-2013 21:03:20

Atharos
Contributors
Registered: 03-05-2013
Posts: 7

Re: Problem with $hashed.part

yikes Thanks for the quick answer! Ill keep on testing big_smile
I have another little problem: when i want to render an image, even if Dreamweaver renders it correctly, I found no way of maken the page draw it.
Do I have to write the path in a certain way for it to work?

Thanks!

Offline

#6 04-05-2013 21:14:37

Thomas
Administrator
Registered: 10-03-2013
Posts: 897

Re: Problem with $hashed.part

Render an image? Do you mean showing an image with the HTML img tag? You can just use it with a path relative to the project root (where the index.php file is), so it'd be

img/yourimage.png

Offline

#7 05-05-2013 00:47:52

Atharos
Contributors
Registered: 03-05-2013
Posts: 7

Re: Problem with $hashed.part

I'll try it as soon as i return home. Another question: is there any chance to use those arrows from the main screen (the ones with the effect at mouseup) as buttons in other pages or sidebars?
Thanks, Thomas!

Offline

#8 05-05-2013 10:21:36

Thomas
Administrator
Registered: 10-03-2013
Posts: 897

Re: Problem with $hashed.part

those arrows are just images located in img/arrows wink

Offline

Board footer

Powered by FluxBB